Ir al contenido principal

Problemas con los scripts, otra vez

Ayer trabajé para implementar la sugerencia que me dejó spoke en el comentario para solucionar el raro problema de los scripts en Windows. No me había percatado que Ogre tiene sus propias funciones de manejo de archivos, que pueden ser muy útiles. Me tomó cierto tiempo cogerles la vuelta y desde ahora les doy  un consejo: es necesario cerrar adecuadamente el archivo. Aún cuando la clase era una variable local de una función, al volver a llamar dicha función la aplicación explotaba si no se cerraba el archivo. Cerrarlo destruye la instancia y elimina cualqueir problema.
Luego encontré otro fallo muy singular. Los scripts estaban dando errores sintácticos graves, al revisarlos me percaté que solo el primero se carga bien, los siguientes se "contaminan" de alguna forma con el valor anterior de la cadena. He intentado usando la función clear() de std::string, igualando la cadena a "", pero nada. En cambio, esto no sucede en Linux. ¿Alguien me puede dar una idea de qué está sucediendo? Porque la verdad que me he quedado perdido en un campo de lechugas.

Comentarios

  1. Creo recordar que me encontre con el mismo problema.

    ¿Estas usando streams para leer los scripts?

    ResponderEliminar
  2. Sí, estoy usando ifstream. Me he asegurado de hacer un clear() a todas las cadenas donde se almacena el script en algún momento, así que yo también pienso que el problema puede estar en la lectura de los archivos.

    ResponderEliminar
  3. Bueno, lo qu yo tengo implementado es tal que:

    class ScriptManager : public Ogre::ResourceManager y ademas Singleton

    De forma que solo puede haber uno.

    class Script : public Ogre::Resource que es la que contiene el stream del script.

    Ogre::DataStreamPtr mStream;

    A la hora de ejecutar el script lo leo del stream y ejecuto tal y como te indique en el otro post.

    Recuerdo el problema que comentas, y a fecha de hoy no he logrado encontrar en mi historico de cambios cuando lo solucione.

    ¿Que version de lua estas usando?

    ResponderEliminar
  4. Estoy usando la 5.1. Voy a comparar bien mi código con este, porque creo que no estoy usando DataStreamPtr, sino otra clase.

    ResponderEliminar
  5. Creo recordar que tenia algo que ver con la versión de lua, pero no estoy seguro al 100% ¿has probado a recompilar desde cero?

    Yo estoy usando lua 5.1.4 y luabind 0.8 (pendiente de actualizar a la 0.9)

    También es cierto que no reutilizo el DataStreamPtr sino que tengo uno por cada script.

    ResponderEliminar

Publicar un comentario