Ir al contenido principal

El portage de Gentoo es un desastre?

No me queda otra cosa por pensar. A estas alturas, aún no tenemos Ogre 1.7, retenido por falta de freeimage, que tampoco se ha reintegrado al portage. Para más inri, me encuentro hace un par de días que para actualizar a xorg-server 1.7, necesario para instalar el Catalyst 10.5, hace falta el util-macros 1.7. Sencillo, no es así? Pues no, porque util-macros 1.7 está en el portage, pero el fuente no. La solución es sencilla: bajar a mano el tar.bz.
No obstante, los problemas no terminan ahí. El snapshot del portage que tenía no se ajusta exactamente con las dependencias de xorg-server, que requiere gl 7.1, pero solo el 7.0 está disponible y otro paquete llamado xf86vm que en teoría es parte de glproto. Tendría que ver si es necesario desenmascararlo, porque luego de preguntar en el foro, nadie me supo dar respuesta.
Con situaciones así, cualquiera se plantea seriamente cambiar de distribución.

Comentarios

  1. yo hace rato me cambie a arch ahora estoy pensando en probar http://www.calculate-linux.org/en la cual esta basada en gentoo pero con su propio repo de portage xorg-server 1.7 esta marcado como estable y los Catalyst son los 10.7 el problema lo seguis teniendo con ogre

    ResponderEliminar
  2. Calculate Linux lo descubrí ayer y estoy pensando en probarlo. De todas formas parece que tendré que instalar freeimage, CEGUI y Ogre a mano.

    ResponderEliminar
  3. deberías darle una oportunidad a arch los paquetes están prácticamente e su ultima versión ejemplo ogre http://www.archlinux.org/packages/community/x86_64/ogre/
    y7 yaourt es una gran herramienta para manejar los paquetes con yaourt -Sb ogre la instalacion se hace desde las fuentes

    ResponderEliminar
  4. Veo que la descarga del Code CD de arch es mas pequeña que la de Calculate, creo que empezaré por ahí. aunque no me gusta que hayan pasado el soporte de los drivers de ati a los usuarios.

    ResponderEliminar

Publicar un comentario